/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found

When running encore run facing this error.

Compiling application source code… Failed: ~/.encore/encore-go/bin/go: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.32' not found (required by ~/.encore/encore-go/bin/go) ~/.encore/encore-go/bin/go: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.34’ not found (required by ~/.encore/encore-go/bin/go)

Hey, sorry to hear that. What version of Encore do you have installed and what Linux distribution and version are you running?

Hey @andre
Thanks for responding.
I am using encore version v1.14.1
Distributor ID: Ubuntu
Description: Ubuntu 20.04.5 LTS
Release: 20.04
Codename: focal

For Glib
ldd (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31
Which is latest for focal.

Thanks :slight_smile:

Hey @kapilatrey95, most likely this was caused by our build machines using a later version of Ubuntu to build the release. I’ve now tagged a new release, Encore v1.14.2, which is built with Ubuntu 20.04. Can you try installing that and see if it fixes your issue?

@andre Thanks a lot
It worked like a charm.

Thanks again.

Great, thanks very much for the bug report and glad to hear it works now!